Compilar Mednafen WIP en Ubuntu


Hola muy buenas , les explicare , rapida y sencillamente como compilar , estas versiones “WIP” del Mednafen . antes de que me pregunten .

El mednafen es un Emulador Multi-Consolas capaz de Emular :

1 – Nintendo Entertainment System ( N.e.s )

2 – Super N.e.s

3 – GameBoy / Original , Pocket / Color / Advance

4 – Sega Master System / Master Drive / Genesis / Saturn

5 – Game Gear

6 – NeoGeo Pocket

7 – PC-Engine / PC-Engine CD / TurboGrafx 16

8 – Atari Lynx

9 – PC-Fx

10 – WonderSwan / WonderSwan Color

11 – Sony PlayStation 1

Muy bien entra en “ESTA PAGINA” y obten la ultima version “WIP” del Mednafen ( WIP = Work In Progress / Trabajo en Progreso ) del Mednafen , para compilarlo en Ubuntu en su ultima version , requeriras GCC & G++ , ahora abre una terminal y usa los siguientes comandos , luego de descargar y extraer tu mednafen😀

inukaze@Inukaze: ~/Descargas/mednafen$ sudo apt-get install -y gcc-4.5 \ 
gcc-4.5-base gcc-4.5-locales gcc-4.5-multilib gcc-4.5-plugin-dev \
g++-4.5 g++-4.5-multilib lib64stdc++6 libstdc++6-4.5-dev libgmp3-dev \
libcdio-dev libsndfile1-dev
inukaze@Inukaze:~/Descargas/mednafen$ whereis gcc-4.5
gcc-4: /usr/bin/gcc-4.3 /usr/bin/gcc-4.5 /usr/bin/gcc-4.1 /usr/bin/gcc-4.4 /usr/bin/gcc-4.0
inukaze@Inukaze:~/Descargas/mednafen$ export CC=/usr/bin/gcc-4.5
inukaze@Inukaze:~/Descargas/mednafen$ ./configure
 checking for gcc... /usr/bin/gcc-4.5
 checking if /usr/bin/gcc-4.5 supports -fno-rtti -fno-exceptions... no
 checking for /usr/bin/gcc-4.5 option to produce PIC... -fPIC -DPIC
 checking if /usr/bin/gcc-4.5 PIC flag -fPIC -DPIC works... yes
 checking if /usr/bin/gcc-4.5 static flag -static works... yes
 checking if /usr/bin/gcc-4.5 supports -c -o file.o... yes
 checking if /usr/bin/gcc-4.5 supports -c -o file.o... (cached) yes
 checking whether the /usr/bin/gcc-4.5 linker (/usr/bin/ld) supports shared libraries... yes
inukaze@Inukaze:~/Descargas/mednafen$ make CXX=g++-4.5 && sudo make install

 

PD : Uso el “Gelide” para cargar mis JUEGOS , usando esta versión del emulador :=)

Una respuesta to “Compilar Mednafen WIP en Ubuntu”

  1. PICCORO Lenz McKA Says:

    mednafen wip es la versión 0.9 de la serie la cual ya emula snes y psx, sin embargo ahora adicional necesita OpenGL. mas problemas para linux dado OpenGL no tiene soporte por defecto en ati y NVIDIA recientes.. es mas en las recientes dan problemas ya que son “discreta”(duales) en laptops..

    recomendable es las versiones viejas es decir la 0.8 sin soporte snes ni megadrive ni psx para estos mejor snes9x 1.43 y pcsxr este ultimo ya esta en todas las rostros en los repos..

    venenux ya tiene todo esto precompilados y empaquetados en su repo en el gogle group los enlaces

    los que aun quieran usar el lento mednsfen wip o 0.9.X ya también esta disponible en los reposde las distros

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s


A %d blogueros les gusta esto: