Ip-Changer


Metodo Manual :

Este metodo , a algunos seguro les parecera a simple vista complicado pero no lo es , de hecho es muy sencillo siempre y cuando cumplan con los “PRE-Requisitos” para su compilacion manual

PRE-Requisitos ( Deficientes ) : Son con versiones menores con los que crearon el proyecto pero a mi me funciono en Ubuntu Hardy , como la mayoria tiene distros mas nuevas no creo que les afecte mucho

1 – Qt4 : Version 4.4.0

2 – Cmake : Version 2.4.7

3 – Boost : Version 1.36 ( PPA )

4 – Ahora instala desde tu repositorio : libqt4-dev , cmake , libboost-regex-dev

Bien ahora vamos a descargar el código fuente , la versión mas actual que consigamos del “IP-CHANGER!” , Una vez descargado lo descomprimimos , y se crea la carpeta “ip-changer” , ahora abrimos una terminal para quienes nunca hayan usado la terminal , fijense bien en que sitio del disco duro se guarda su archivo o mejor si estan usando el Mozilla Firefox , pueden darle clic derecho encima del archivo recien descargado y luego hacer clic en la opcion del sub-menu que aparecio “Abrir carpeta Contenedora” y copian la ruta

Para agregar el Soporte para las versiones 8.56 & 8.57 , hagan clic en el numero de la version y pongan el archivo en “/ip-changer/ip-changer/versions”

====EN LA TERMINAL (Ejemplo)====

#> cd SHIFT+INSERT ( para los que copiaron la ruta , si no)

#> cd $HOME

#> cd Descargas

#> cd ip-changer

#> cmake .

Si no ven mal se escribe ( cmake punto )

ip-changer # cmake .
– The C compiler identification is GNU
– The CXX compiler identification is GNU
– Check for working C compiler: /usr/bin/gcc
– Check for working C compiler: /usr/bin/gcc — works
– Detecting C compiler ABI info
– Detecting C compiler ABI info – done
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ — works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info – done
– Looking for Q_WS_X11
– Looking for Q_WS_X11 – found
– Looking for Q_WS_WIN
– Looking for Q_WS_WIN – not found.
– Looking for Q_WS_QWS
– Looking for Q_WS_QWS – not found.
– Looking for Q_WS_MAC
– Looking for Q_WS_MAC – not found.
– Found Qt-Version 4.5.0
– Boost version: 1.36.0
– Found the following Boost libraries:
– Configuring done
– Generating done
– Build files have been written to: /root/Descargas/ip-changer

ip-changer # make

Scanning dependencies of target pList

[  9%] Building CXX object ip-changer/pList/CMakeFiles/pList.dir/pList.cpp.o

Linking CXX static library libpList.a

[  9%] Built target pList

[ 18%] Generating qrc_resources.cxx

[ 27%] Generating ui_mainwindow.h

[ 36%] Generating moc_mainwindow.cxx

Scanning dependencies of target ip-changer

[ 45%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/main.cpp.o

[ 54%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/mainwindow.cpp.o

[ 63%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/history.cpp.o

[ 72%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/client.cpp.o

[ 81%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/process.cpp.o

[ 90%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/moc_mainwindow.cxx.o

[100%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/qrc_resources.cxx.o

Linking CXX executable ip-changer

[100%] Built target ip-changer

ip-changer # make install

[  9%] Built target pList

[100%] Built target ip-changer

Install the project…

– Install configuration: “”

– Up-to-date: /usr/bin/ip-changer

– Installing: /usr/share/ip-changer/versions

– Installing: /usr/share/ip-changer/versions/7.92

– Installing: /usr/share/ip-changer/versions/8.10

– Installing: /usr/share/ip-changer/versions/8.00

– Installing: /usr/share/ip-changer/versions/7.91

– Installing: /usr/share/ip-changer/versions/8.52

– Installing: /usr/share/ip-changer/versions/8.56

– Installing: /usr/share/ip-changer/versions/8.20

– Installing: /usr/share/ip-changer/versions/8.57

– Installing: /usr/share/ip-changer/versions/7.90

– Installing: /usr/share/ip-changer/versions/8.50

– Installing: /usr/share/ip-changer/versions/8.30

– Installing: /usr/share/ip-changer/versions/8.11

– Installing: /usr/share/ip-changer/versions/8.31

– Installing: /usr/share/ip-changer/versions/8.40

– Installing: /usr/share/ip-changer/versions/8.55

– Installing: /usr/share/ip-changer/versions/8.22

– Installing: /usr/share/ip-changer/versions/8.42

– Installing: /usr/share/ip-changer/versions/8.53

– Installing: /usr/share/ip-changer/versions/8.41

– Installing: /usr/share/ip-changer/versions/8.21

# echo “Ahora esta instalado puedes ejecutarlo con : “
# ip-changer

Tibia Linux Ip-Changer QT4

Listo , si tienen el problema de que esto les tranca el teclado , el sistema grafico , pero el mouse sigue respondiendo entonces tendrar que modificar manualmente el archivo “8.57” por ejemplo , dependiendo de la version que quieres jugar en el OT Server de tu preferencia , si es la 8.57 puedes visitar la comunidad de OTFan en “ESTA PAGINA
En otra seccion explicare como “Compilar lsearch” para que puedan obtener la informacion para las versiones del “Ip-Changer” de Linux para que la intenten agregar manualmente.

QT4.3 IpChanger -
Binario PreCompilado por Inukaze

Nota : El PreCompilado no les funcionara a todos , si lo ejecutan en la terminal algunos veran algun error como “No se puede ejecutar el binario” o “binario no valido” , por eso les recomiendo compilarlo manualmente ;)

Pueden usar la version 8.57

En el “Mp3 Serv” , tendras que crearte la cuenta y crearte al personaje

OTServ ip-changer

Lista con los 4 Personajes Creados :D

OTServ ip-changer

15 comentarios to “Ip-Changer”

  1. Max Says:

    por alguna razon no me funciona tengo ubuntu tengo ubuntu 10.4.
    Cuando llego a la parte de cmake. me dice q no se encuentra el archivo no sé q puede ser ojala y me pudas ayudar

  2. Max Says:

    lo de hace rato ya lo solucione ahora tengo otra bronca XD
    maximo@maximo-desktop:~/Descargas/ip-changer$ cmake .
    — The C compiler identification is GNU
    — The CXX compiler identification is unknown
    — Check for working C compiler: /usr/bin/gcc
    — Check for working C compiler: /usr/bin/gcc — works
    — Detecting C compiler ABI info
    — Detecting C compiler ABI info – done
    CMake Error: your CXX compiler: “CMAKE_CXX_COMPILER-NOTFOUND” was not found. Please set CMAKE_CXX_COMPILER to a valid compiler path or name.
    — Looking for Q_WS_X11
    — Looking for Q_WS_X11 – found
    — Looking for Q_WS_WIN
    — Looking for Q_WS_WIN – not found.
    — Looking for Q_WS_QWS
    — Looking for Q_WS_QWS – not found.
    — Looking for Q_WS_MAC
    — Looking for Q_WS_MAC – not found.
    — Found Qt-Version 4.6.2 (using /usr/bin/qmake)
    — Looking for _POSIX_TIMERS
    — Looking for _POSIX_TIMERS – found
    — Boost version: 1.40.0
    — Found the following Boost libraries:
    — Configuring incomplete, errors occurred!
    maximo@maximo-desktop:~/Descargas/ip-changer$
    sera por que tengo las verciones mas nuevas?

    • inukaze Says:

      No creo a mi me da este resultado :

      [inukaze@Inukaze ip-changer]$ cmake .
      -- The C compiler identification is GNU
      -- The CXX compiler identification is GNU
      -- Check for working C compiler: /usr/bin/gcc
      -- Check for working C compiler: /usr/bin/gcc -- works
      -- Detecting C compiler ABI info
      -- Detecting C compiler ABI info - done
      -- Check for working CXX compiler: /usr/bin/c++
      -- Check for working CXX compiler: /usr/bin/c++ -- works
      -- Detecting CXX compiler ABI info
      -- Detecting CXX compiler ABI info - done
      -- Looking for Q_WS_X11
      -- Looking for Q_WS_X11 - found
      -- Looking for Q_WS_WIN
      -- Looking for Q_WS_WIN - not found.
      -- Looking for Q_WS_QWS
      -- Looking for Q_WS_QWS - not found.
      -- Looking for Q_WS_MAC
      -- Looking for Q_WS_MAC - not found.
      -- Found Qt-Version 4.6.2 (using /usr/bin/qmake)
      -- Looking for _POSIX_TIMERS
      -- Looking for _POSIX_TIMERS - found
      -- Boost version: 1.40.0
      -- Found the following Boost libraries:
      -- Configuring done
      -- Generating done
      -- Build files have been written to: /home/inukaze/Documentos/ip-changer
      
  3. Max Says:

    entonces q cres q pueda ser?

    • inukaze Says:

      Sinceramente , no tengo idea xD.
      Porque hasta donde yo lo veo estamos igual , en Lucid el mio es de 32 Bits.

      Bueno estas tambien en donde descargastes tu ip-changer , o mejor descargalo del sitio oficial nuevamente a ver.

      y bueno ya sabes , comprueba que tienes los “-dev” de esas librerias en “Ubuntu” para ver si es por eso , como todo mi sistema tiene los “-dev” & “-dbg” de casi todos los paquetes que tengo instalado xD es raro que me de un error asi

      $ cmake ESPACIO PUNTO => $ cmake .

  4. Max Says:

    noob aqui XD

    como instalo los paquetes ó como checo si los tengo?

    • Inukaze Says:

      Entra en tu gestor de paquetes ya sea “Synaptic” u otro , si estan en “Gnome” esta en “Menu > Sistema > Administracion > Gestor de Paquetes Synaptic” , y alli busca preferiblmente por nombre solamente , por ejemplo :

      libqt4-dev
      cmake
      libboost-regex-dev

      Si no estan los instalas , y vuelves a intentar :D

      Aunque si quieres hacerlo desde una “Terminal”/”Consola”/”CLI”/”Konsole” entonces usa el siguiente comando

      sudo apt-get install libqt4-dev cmake libboost-regex-dev

      te pedira la contraseña , cuando la escribas , es como si no escribieras nada , por medidas de seguridad anti-mirones lammers xD , escribe tu contraseña confiando , y presiona enter , y luego “S” y presiona enter , y listo deberia empezar a instalar si no tienes eso listo :)

  5. nand0 Says:

    podi poner la version 8.6? porfa y me salio de lujo el ip vale

  6. nand0 Says:

    que si puedes agregar el soporte para los servidores 8.6

  7. nand0 Says:

    porfa agrega el soporte 8.6 o dime cual es la rsa

    • Inukaze Says:

      Ya vistes si esto tiene ese soporte : ?

      Ip-Changer 1.5.7 Official

      Bueno la verdad , es que a muchos , nos dio resultados distintos la version 8.6 , tendras que hacer lo mismo que yo en “ESTE SITIO”

      Lee atentamente mis post , ya que uno es bastante largo , con todas las direcciones que tube que probrar xD para allar “Mi Resultado” ya que a otros les funciono de otra manera

      Para mi , funciono el “Ejemplo N°5″ : Prueba a ver que tal te va ;=)

      # 5 From Internet 1: Same 8.56 & 8.57

      LoginServersStart 0x85818c0
      ServerStep 0x70
      PortStep 0x64
      RSA 0x8388ee0
      ServersCount 10

  8. eduar Says:

    como hago para instalarlo para linux

  9. desesperadoooo Says:

    Brother ayuuuuuuuuuuudaaaaaaaa
    pdvsa@pdvsa-3000-N200:~$ cd /home/pdvsa/Descargas
    pdvsa@pdvsa-3000-N200:~/Descargas$ cd ip-changer
    pdvsa@pdvsa-3000-N200:~/Descargas/ip-changer$ cmake .
    — The C compiler identification is GNU 4.7.2
    — The CXX compiler identification is GNU 4.7.2
    — Check for working C compiler: /usr/bin/gcc
    — Check for working C compiler: /usr/bin/gcc — works
    — Detecting C compiler ABI info
    — Detecting C compiler ABI info – done
    — Check for working CXX compiler: /usr/bin/c++
    — Check for working CXX compiler: /usr/bin/c++ — works
    — Detecting CXX compiler ABI info
    — Detecting CXX compiler ABI info – done
    — Looking for Q_WS_X11
    — Looking for Q_WS_X11 – found
    — Looking for Q_WS_WIN
    — Looking for Q_WS_WIN – not found.
    — Looking for Q_WS_QWS
    — Looking for Q_WS_QWS – not found.
    — Looking for Q_WS_MAC
    — Looking for Q_WS_MAC – not found.
    — Found Qt4: /usr/bin/qmake (found version “4.8.3”)
    — Configuring done
    — Generating done
    — Build files have been written to: /home/pdvsa/Descargas/ip-changer
    pdvsa@pdvsa-3000-N200:~/Descargas/ip-changer$ make
    Scanning dependencies of target pList
    [ 9%] Building CXX object ip-changer/pList/CMakeFiles/pList.dir/pList.cpp.o
    Linking CXX static library libpList.a
    [ 9%] Built target pList
    [ 18%] Generating qrc_resources.cxx
    [ 27%] Generating ui_mainwindow.h
    [ 36%] Generating moc_mainwindow.cxx
    Scanning dependencies of target ip-changer
    [ 45%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/main.cpp.o
    [ 54%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/mainwindow.cpp.o
    [ 63%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/history.cpp.o
    [ 72%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/client.cpp.o
    [ 81%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/process.cpp.o
    [ 90%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/moc_mainwindow.cxx.o
    [100%] Building CXX object ip-changer/CMakeFiles/ip-changer.dir/qrc_resources.cxx.o
    Linking CXX executable ip-changer
    [100%] Built target ip-changer
    pdvsa@pdvsa-3000-N200:~/Descargas/ip-changer$ make install
    [ 9%] Built target pList
    [100%] Built target ip-changer
    Install the project…
    — Install configuration: “”
    — Installing: /usr/bin/ip-changer
    CMake Error at ip-changer/cmake_install.cmake:50 (FILE):
    file INSTALL cannot copy file
    “/home/pdvsa/Descargas/ip-changer/ip-changer/ip-changer” to
    “/usr/bin/ip-changer”.
    Call Stack (most recent call first):
    cmake_install.cmake:37 (INCLUDE)

    make: *** [install] Error 1

  10. Arquimedes rivero Says:

    donde lo descargo

Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s


Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

A %d blogueros les gusta esto: